29 lines
1.0 KiB
Diff
29 lines
1.0 KiB
Diff
--- a/nixos/lib/build-vms.nix
|
|
+++ b/nixos/lib/build-vms.nix
|
|
@@ -30,10 +30,10 @@ rec {
|
|
buildVM =
|
|
nodes: configurations:
|
|
|
|
- import ./eval-config.nix {
|
|
+ import <nixpkgs/nixos/lib/eval-config.nix> {
|
|
inherit system;
|
|
modules = configurations ++ extraConfigurations;
|
|
- baseModules = (import ../modules/module-list.nix) ++
|
|
+ baseModules = (import <nixpkgs/nixos/modules/module-list.nix>) ++
|
|
[ ../modules/virtualisation/qemu-vm.nix
|
|
../modules/testing/test-instrumentation.nix # !!! should only get added for automated test runs
|
|
{ key = "no-manual"; documentation.nixos.enable = false; }
|
|
|
|
|
|
services.connman doesn't exist in stable nixpkgs
|
|
--- a/nixos/modules/virtualisation/qemu-vm.nix
|
|
+++ b/nixos/modules/virtualisation/qemu-vm.nix
|
|
@@ -620,7 +620,6 @@ in
|
|
|
|
# Wireless won't work in the VM.
|
|
networking.wireless.enable = mkVMOverride false;
|
|
- services.connman.enable = mkVMOverride false;
|
|
|
|
# Speed up booting by not waiting for ARP.
|
|
networking.dhcpcd.extraConfig = "noarp";
|