27 lines
781 B
Nix
27 lines
781 B
Nix
{ lib, fetchFromGitHub , rustPlatform , pkg-config, openssl }:
|
|
|
|
rustPlatform.buildRustPackage rec {
|
|
pname = "ord";
|
|
version = "0.5.1";
|
|
|
|
src = fetchFromGitHub {
|
|
owner = "casey";
|
|
repo = pname;
|
|
rev = version;
|
|
#sha256 = lib.fakeSha256;
|
|
sha256 = "sha256-3lOEFNhG9NU0+D4sGvfbKgFLj4F6Bhgt1R7zRSzKhzo=";
|
|
};
|
|
|
|
cargoSha256 = "sha256-koJgU4KEXK7468weJY57yP7f1tSB9nImvVa5CbNQDDg=";
|
|
|
|
nativeBuildInputs = [pkg-config];
|
|
buildInputs = [openssl];
|
|
|
|
meta = with lib; {
|
|
description = "ord is an index, block explorer, and command-line wallet. Ordinal theory imbues satoshis with numismatic value, allowing them to collected and traded as curios.";
|
|
homepage = "https://github.com/casey/ord";
|
|
license = with licenses; [cc0];
|
|
mainProgram = "ord";
|
|
};
|
|
}
|